The Ovation Fan Club
The Ovation Fan Club
Forum Search | Statistics | User Listing Forums | Calendars | Albums | Language
Your are viewing as a Guest. ( logon | register )

Random quote: "One good thing about music, when it hits you, you feel no pain." - Bob Marley



Jump to page : 1
Now viewing page 1 [25 messages per page]
iBreadwinner Not working -SOLVED

View previous thread :: View next thread
   The Ovation Fan Club -> Welcome CenterMessage format
 
O-man
Posted 2019-11-29 8:20 PM (#550610)
Subject: iBreadwinner Not working -SOLVED
Joined:
November 2019
Posts: 1

1970's Breadwinner failed to play after long storage and replacement of dead batteries. Ultimately, I de-strung it and removed the electronics and pick guard assembly as a unit. I attached fresh batteries and jumped the circuit board ground wire to the negative side of an exposed guitar cord connected to an amp, this to test for sound. During examination, I pinch squeezed the circuit board and pick guard at the double potentiometer tone control. This activated the pickups, as long as it was pressed. I decided to service the potentiometer for volume and tone in the following manner. I applied a few drops of CAIG Deoxit D100 red liquid into each pot.Each was worked vigorously to spread the chemical within. Next, I used a couple of short sprays of CAIG fader lube, again, vigorously working the knobs. Immediately, the pickups became active, as determined by tapping them with the screwdriver I used on the pickguard screws during removal. I reassembled everything, placing additional double stick tape between the foil shielding and guitar body so it would not get pushed down when I set the circuit board back into the cavity. Additionally, I noticed the dampening foam in the recessed bridge tailpiece cavity was rotted. I replaced it with some cut to size foam pipe insulation material, think swimming pool noodle. To my relief, when all was assembled, strung and plugged in, the guitar worked flawlessly. I played it over an hour just for the sheer joy of fixing what could have been a lost cause. In conclusion, should you find your guitar has a similar fault of not playing after long storage, try my method.
Top of the page Bottom of the page
alpep
Posted 2019-11-30 4:16 PM (#550612 - in reply to #550610)
Subject: Re: iBreadwinner Not working -SOLVED


Joined:
December 2001
Posts: 10410

Location: NJ
fantastic!!!!!
Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [25 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

This message board and website is not sponsored or affiliated with Ovation® Guitars in any way.
Registered to: The Ovation Fanclubâ„¢ Copyright (c) 2001
free counters
(Delete all cookies set by this site)