The Ovation Fan Club
The Ovation Fan Club
Forum Search | Statistics | User Listing Forums | Calendars | Albums | Language
Your are viewing as a Guest. ( logon | register )

Random quote: "Got time to breathe, got time for music." --Briscoe Darling.



Jump to page : 1
Now viewing page 1 [25 messages per page]
Preacher Deluxe Tone Knob Problem

View previous thread :: View next thread
   The Ovation Fan Club -> Welcome CenterMessage format
 
paessex
Posted 2018-01-09 12:17 PM (#539730)
Subject: Preacher Deluxe Tone Knob Problem


Joined:
January 2018
Posts: 2

Hello new member here with a classic solid body. Last spring I bought an original black PD as I sold one 20+ years ago (original owner) and nothing ever felt better in my hands. Since my purchase the tone knob was totally cutting the output sound after about 1.5 – not a good tone setting with almost max bass but I often noodle around unplugged and the guitar was in very good shape with original case and bought at a fair price, so I took a chance. This past week I set out to fix the problem – I removed the pickguard, cleaned and lubed the tone pot contacts, carefully inspected for any other problems and reassembled only to have the same problem lingering.

I have spent several hours searching these archives and found these pre-amp problems to be fairly common and now 30+ years later repair parts are (far) no longer available as most postings on this subject were at least 10 years old. So I believe I have three options I am seeking advice: continue to try to fix the problem, bypass the pre-amp or install new pick-ups and wiring harness (I realize many of you will not agree with this path).

First, is my problem likely the unique, dual/stacked pot, a capacitor or some other component? I have seen similar wire diagrams for the BW but not the 1283 model PD. I understand I can measure the pot resistance (top and bottom) on outer lugs after I get back in there and could potentially re-build the pot? Realistic? Any further guidance? Is there someone that can competently fix this? What is the success rate to fix this?

Second, can the pre-amp be successfully by-passed? Any directions available? I understand these pick-ups may not do well without the pre-amp, but can’t that be overcome with amp settings?

If the parts don’t exist or this is a difficult/risky/expensive fix, what are my best options to remove the active electronics and install new (mini) humbuckers? Can a new PD pickguard be acquired/made?

Thanks in advance for your replies, I am glad to find you and sorry for since a lengthy opening post.
Top of the page Bottom of the page
alpep
Posted 2018-01-09 2:43 PM (#539731 - in reply to #539730)
Subject: Re: Preacher Deluxe Tone Knob Problem


Joined:
December 2001
Posts: 10141

Location: NJ
welcome to the forum
you can post in any section now
if you take a pic of the pot I may have a replacement
Top of the page Bottom of the page
paessex
Posted 2018-01-09 4:35 PM (#539733 - in reply to #539730)
Subject: Re: Preacher Deluxe Tone Knob Problem


Joined:
January 2018
Posts: 2

Wow alpep that would be awesome if you did. So you think this is the problem as it all functions at the lowest tone levels?

As i have it restrung I can't get a pic but i can describe it in good detail. The tone pot is a concentric, split shaft, dual/stack with opposing lugs (three on each side at 180 degrees apart). the long lugs are soldered directly to the CB.

Thanks!



Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [25 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

This message board and website is not sponsored or affiliated with Ovation® Guitars in any way.
Registered to: The Ovation Fanclub™ Copyright (c) 2001
free counters
(Delete all cookies set by this site)